GENVI

ENVI Classic Tutorial:
Vector Overlay and
GIS Analysis

Vector Overlay and GIS ANalySis ... 2
Sources and Files Used inthis Tutorial ... . .. 2
Required Files ... il 3

Vector Overlay and GIS Analysis Capabilities in ENVI Classic ..., 5

Vector Overlay and GIS Analysis Concepts inENVIClassic ........ ..., 7
ENVIVector Files (.eVl) ... 7
The Available Vectors List . ... ... 7
Create World Boundaries . ... 8
The Vector Parameters Dialog and Vector Window Menu ........... .. ... ... 9
ENVI Classic AttibUtes ... .. o e 10

Part 1: Stand-Alone Vector GlS ... .. 12
Opena Shapefile . iiiiiiiiiiil. 12
Work with Vector Point Data . .......... ... e 12
Create USA State Boundaries Using IDLMap Sets ... ... .. i 13
Work with Vector Polygon Data ... ... 13
Retrieve Vector Information and Attributes ... .. iiiiil... 14
View Attributes and Use Point-and-Click Query ... .. il 14
QUENY At DULES . 14
Add aMap Key inthe Vector Window ... ... e 15

Part 2: Rasterand Vector Processing . ... ... .. 17
Load Image Data to Combined Image/VectorDisplay ............ ..o, 17
Open a Vector Layerand Load to Image Display ... il 17
Track Attributes with the Cursor ... .. 17
Heads-up (On-screen) Digitizing ... ... ... .. 18
Edit VeCtor Layers ... 19
QUENY OPEIatioNS .. ... ..ot 20
Convert Vectors to ROIS ... ... 20
Display Image Map ResUItS ... ..o e 21
Export ROIto Vector Layer ... . . . 21
Export a Classification Image to Vector Polygons .. ... il 22




ENVI Classic Tutorial: Vector Overlay and GIS Analysis @ENV|

Vector Overlay and GIS Analysis

This tutorial introduces ENVI Classic’s vector overlay and GIS analysis capabilities using vector data
from Esri’s Maps and Data CD-ROM; a simulated 4 m resolution Space Imaging/EOSAT multispectral
dataset; and associated vector data of Gonzales, California, USA.

Part 1 of this tutorial demonstrates the following:
o Stand-alone vector GIS analysis, including input of shapefiles and associated DBF attribute files
¢ Display in vector windows
¢ Viewing and editing attribute data
¢ Point-and-click spatial query
o Math and logical query operations
Part 2 of this tutorial demonstrates the following:
e ENVI Classic’s combined image display/vector overlay and analysis capabilities
e Cursor tracking with attribute information
¢ Point-and-click spatial query
e Heads-up digitizing and vector layer editing
e Generation of new vector layers using math and logical query operations

e Raster-to-vector conversion of ENVI Classic regions of interest (ROIs) and classification
images

e ENVI Classic’s vector-to-raster conversion, using vector query results to generate ROIs for
extraction of image statistics and area calculations

Sources and Files Used in this Tutorial

The data used in this tutorial are provided courtesy of the Environmental Systems Research Institute Inc.
and Space Imaging/EOSAT and may not be redistributed without explicit permission from those
organizations.

ESRI Data and Maps Version 1 CD-ROM

Example data used in Part 1 of this tutorial come from the ESRI Data and Maps Version 1 CD-ROM
distributed with ArcView Version 3.0. Exelis strives to maintain import/export compatibility with ESRI
GIS products and data formats, including ArcView shapefiles, ArcGRID files, and ArcInfo export files
(.e00, non-compressed).

Space Imaging/EOSAT CarterraTM Agriculture Sampler Data

Example images and vector data used in Part 2 of this tutorial come from the Space Imaging/EOSAT
Carterra Agriculture Sampler CD-ROM (Copyright © 1997, Space Imaging/EOSAT) and are used with
their explicit permission. This sample dataset covers an agricultural area near Gonzales, California,
USA-—the north-central portion of the Palo Escrito Peak, CA USGS 7.5 minute quadrangle. The digital
imagery are simulated data products designed to be similar to the space-based image data products
collected and distributed by Space Imaging/EOSAT in early 1998. Space Imaging/EOSAT provides
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these simulated data products as examples of information extracted from their imagery products. The
simulated imagery datasets were generated from digital image data collected by an airborne
multispectral scanner. The airborne data were geometrically rectified, corrected for solar effects, and
mosaicked at a spatial resolution simulating the Carterra data products. However, radiometric and
geometric differences exist between these data and satellite-based products planned for delivery. Please
see the Carterra Sampler readme.txt file included in the si_eosat subdirectory for additional information.

Required Files

Download data files from the Exelis website.

Scroll to the "Vector Overlay and GIS Analysis" tutorial and click "Download Data." The file 34

Vector GIS.zip contains the data files needed for this tutorial.
Required vector GIS files for Part 1:

File Description

cities.shp (.shx, .dbf) TUSA cities (points)
states.shp (.shx, .dbf) USA states (polygons)

Optional vector GIS files for Part 1:

File Description

counties.shp (.shx, .dbf) USA counties (polygons)
drainage.shp (.shx, .dbf) TUSA states (polygons)

lakes.shp (.shx, .dbf) USA lakes (polygons)
rivers.shp (.shx, .dbf) USA rivers (polylines)
roads.shp (.shx, .dbf) USA roads (polylines)

Required image files for Part 2:

File Description
0826_ms.img (.hdr) 4-m multispectral data and ENVI header file

Required image files for Part 2:

File Description
can_tmr.img (.hdr) Cafion City TM data and ENVI header
can_sam.img (.hdr) Cafion City SAM classification and ENVI header
can_pcls.img (.hdr) Cafon City parallelepiped classification and ENVI header

can_sv.img (.hdr) Sieved classification (threshold = 5) and ENVI header
can_clmp.img (.hdr) Clumped (5 x 5) after sieve and ENVI header
can_tml.roi Caifion City TM ROI #1

can_tm2.roi Cafion City TM ROI #2

Required vector GIS files for Part 2:

File Description
vectors.shp (.shx, .dbf) Field outlines (polygons)
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Optional vector GIS files for Part 2:

File
gloria.evf (.dbf)
lanini.evf (.dbf)
sharpe.evf (.dbf)

si eosat.vec

Description

Query results (polygons)
Query results (polygons)
Query results (polylines)

ENVI Classic vector template for the above three vectors
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Vector Overlay and GIS Analysis Capabilities in
ENVI Classic

ENVI Classic provides extensive vector overlay and GIS analysis capabilities. These include the
following:

Import support for industry-standard GIS file formats, including shapefiles and associated DBF
attribute files, ArcInfo interchange files (. e00, uncompressed), Maplnfo vector files (.mif) and
attributes from associated .mid files, Microstation DGN vector files, DXF, and USGS DLG and
SDTS formats. ENVI Classic uses an internal ENVI Vector Format (EVF) to maximize
performance.

Vector and image/vector display groups provide a stand-alone vector plot window for displaying
vector data and composing vector maps. More importantly, ENVI Classic provides vector
overlays in display groups (Image windows, Scroll windows, and Zoom windows).

You can generate world boundary vector layers, including low- and high-resolution political
boundaries, coastlines, and rivers, and USA state boundaries. You can display all of these in
vector windows or overlay them in image display groups.

You can perform heads-up (on-screen) digitizing in a vector or raster display group. Heads-up
digitizing provides an easy means of creating new vector layers by adding polygons, lines, or
points.

Image- and vector window-based vector editing allows you to modify individual polygons,
polylines, and points in vector layers using standard editing tools, taking full advantage of the
image backdrop provided by raster images in ENVI Classic.

ROlIs, specific image contour values, classification images, and other raster processing results
can be converted to vector format for use in GIS analysis.

Latitude/longitude and map coordinate information can be displayed and exported for image-
to-map registration. Attribute information can be displayed in real-time as each vector is selected.

ENVI Classic supports linked vectors and attribute tables with point-and-click query for both
vector and raster displays. Click on a vector in the display group, and the corresponding vector
and its associated information is highlighted in the attribute table. Click on an attribute in the
table, and the display scrolls to and highlights the corresponding vector.

Scroll and pan through rows and columns of vector attribute data. Edit existing information or
replace attributes with constant values, or with data imported from ASCII files. Add or delete
attribute columns. Sort column information in either forward or reverse order. Export attribute
records as ASCII text.

Query vector database attributes directly to extract information that meets specific search
criteria. You can perform GIS analysis using simple mathematical functions and logical operators
to produce new information and layers. Results can either be output to memory or to a file for
later access.

You can set vector layer display characteristics and modify line types, fill types, colors, and
symbols. Use attributes to control labels and symbol sizes. Add custom vector symbols.

You can reproject vector data from any map projection to another.
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¢ You can convert vector data to raster ROIs for extraction of statistics, calculation of areas, and
use in ENVI Classic’s many raster analysis functions.

o Generate maps using ENVI Classic annotation in either vector or image windows. Set border
widths and background colors, and configure graphics colors. Automatically generate vector layer
map keys. Insert objects such as rectangles, ellipses, lines, arrows, symbols, text, and image
insets. Select and modify existing annotation objects. Save and restore annotation templates for
specific map compositions.

¢ Create shapefiles and associated DBF attribute files and indices, or DXF files, from the
internal ENVI Vector Format (EVF). New vector layers generated using ENVI Classic’s robust
image processing capabilities, and changes made to vector layers in ENVI Classic are exported to
industry-standard GIS formats.

o Use ENVI Classic’s direct printing capabilities to output to printers and plotters.
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Vector Overlay and GIS Analysis Concepts in ENVI
Classic

ENVI Classic’s vector overlay and GIS analysis functions generally follow the same paradigms as
ENVI Classic’s raster processing routines, including the same procedures for opening files and the use
of standard dialogs for output to memory or file. The following sections describe some of the basic
concepts.

ENVI Vector Files (.evf)

External vector files imported into ENVI Classic are automatically converted into EVF, with the default
file extension .evf. The EVF format speeds processing and optimizes data storage. When you select
output to memory (instead of to a file), ENVI Classic retains the external vector format without creating
an EVF file.

The Available Vectors List

Much like the Available Bands List used to list and load image bands, the Available Vectors List
provides access to all vector files open in ENVI Classic. It appears when needed, or you can invoke it
by selecting Window > Available Vectors List from the ENVI Classic main menu bar. Vectors are
loaded to either vector or image display groups when you select them from the Available Vectors List
and click Load Selected. If you have an image display group open, you can load the vectors to that
display group, or to a new vector window. In addition to listing and loading vector layers, the Available
Vectors List provides utilities to open vector files, to start new vector windows, to create world
boundaries and new vector layers, and to export analysis results to ROIs (through raster-to-vector
conversion), shapefiles, and ancillary files.
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& Available Vectors List

File Options

B(=1ES

Laver: ci

Laper:
Layer:
Laper:
Laver:
Layer:
Laper:

Auvailable Wector Layers:

countiesz. zhp
drainage. zhp
lakes. shp
rivers. shp
roadz. zhp
states. shp

Mame: Layer: cities.zhp

File: [In kemaon]

Records: 3,557 [3.557 nodes]

Proj: Geographic Lat/Lon [Degreesz]
Daturn: Morth America 1383
Aftributes: Yes

Select All Layers | Deszelect All Layers |

Load Selected | Remove Selected |

Create World Boundaries

ENVI Classic uses IDL map sets to generate low- and high-resolution world boundaries in EVF. Select
Options > Create World Boundaries from the Available Vectors List, or Vector > Create World
Boundaries from the ENVI Classic main menu bar. You can also generate political boundaries,
coastlines, rivers, and USA state boundaries.

High-resolution format is available only if the IDL high-resolution maps are installed. If these are not
currently installed on your system, you can install them using the ENVI Classic Installation CD,

modifying your installation to include the high-resolution maps.
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The Vector Parameters Dialog and Vector Window Menu

When vectors are overlaid on an image, the Vector Parameters dialog appears to let you control the way
vectors are displayed and the functions that are available for vector processing and analysis.

When vectors are loaded into a vector window (not in an image display group), the vector window has
the same menu functions available in the Vector Parameters dialog.

The Vector Parameters dialog and the vector window menu bar allow you to open vector files, import
vector layers from the Available Vectors List, arrange vector layer precedence, set plot parameters, and
annotate plots. They also control the mode of operation in the vector window or image display group,
toggling between cursor query and heads-up digitizing and editing. The Vector Parameters dialog or the
vector window menu initiate ENVI Classic’s GIS analysis functions, including real-time vector
information, attribute viewing and editing, and vector query operations. Finally, the Vector Parameters
dialog and the vector window menu bar provide utilities for exporting analysis results to shapefiles and
ancillary attribute files, or to ROIs (through vector-to-raster conversion). You can also save the current
configuration of vector overlays to a template, so you can later restore them.
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File Made Edit Options Help
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ENVI Classic Attributes

ENVI Classic provides access to fully attributed GIS data in a shapefile DBF format. Attributes are
listed in an editable table, allowing point-and-click selection and editing.

Double-clicking in a particular cell selects that cell for editing. The table also supports full column
substitution using a uniform value and replacement with values from an ASCII file. Options include
adding and deleting individual columns and sorting data forward and backward based on information
within a column. You can save attributes to an ASCII file or to a DBF file.

Point-and-click spatial query is supported in ENVI Classic attribute tables to help you locate key
features in images or in a vector window. Select specific records by clicking the label at the left edge of
the table for a specific row in the table. The corresponding vector is highlighted in a contrasting color in
the image display group or vector window. You can select multiple records, including non-adjacent
records, by holding down the <Ctrl> key as you click the additional row labels.

10
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Part 1: Stand-Alone Vector GIS

This part of the tutorial demonstrates how to use ENVI Classic as a simple stand-alone vector
processing and analysis system for GIS data. You will use data from the Esri Data and Maps 1 CD-

ROM.

Open a Shapefile

1.

From the ENVI Classic main menu bar, select File > Open Vector File. A Select Vector
Filenames dialog appears.

Click the Files of type drop-down list in the Select Vector Filenames dialog, and select
Shapefile.

Select cities. shp. Click Open. The Import Vector Files Parameters dialog appears. This
dialog allows you to select file or memory output, enter an output filename for the ENVI
Classic . evf file, and enter projection information if ENVI Classic is unable to find the
projection information automatically.

Click the Memory radio button. Accept the default values by clicking OK. A status window
indicates the number of vector vertices being read, and the Available Vectors List appears when
the data have been converted.

Select cities. shp in the Available Vectors List and click Load Selected. The Vector
Window #1 dialog appears with USA cities plotted. The default mode (shown in the title bar or in
the lower-right corner of the dialog) is Cursor Query.

Work with Vector Point Data

1.

Click and drag the cursor around in Vector Window #1. Latitudes and longitudes are displayed in
the lower-left corner of the dialog.

Zoom into the contiguous 48 states by positioning the cursor in the far northwest part of the U.S.
and clicking and dragging the middle mouse button to define a box covering the desired region.
Release the middle mouse button in the far southeast part of the U.S. Multiple levels of zoom are
possible. Click the middle mouse button while holding the <Shift> key to zoom into the display
centered on the cursor. Right click in the Vector Window #1 dialog and select Previous Range to
step backward through the previous zoom levels. Right-click and select Reset Range, or click the
middle mouse button in the Vector Window #1 dialog to reset the zoom level and to set the vector
display back to the original range.

Change the symbol used to mark the cities. From the Vector Window #1 menu bar, select Edit >
Edit Layer Properties. An Edit Vector Layers dialog appears. Click the Point Symbol drop-
down list and select Flag. Click OK. You can add your own symbols by defining them in the file
usersym. txt in the menu directory of your ENVI Classic installation.

Experiment with changing the color, symbol, and size. Click Preview to view your changes as
you go.

12
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Create USA State Boundaries Using IDL Map Sets

1.

From the Available Vectors List menu bar, select Options > Create World Boundaries. The
Create Boundaries dialog appears.

Select the USA States check box, select the Memory radio button, and click OK to create the
USA States boundaries, which is loaded into the Available Vectors List.

In the Available Vectors List, select USA States [full range] and click Load Selected. The Load
Vector dialog appears.

Select Vector Window #1 as the location to load the vector. Click OK. The cities and the state
boundaries both appear in the Vector Window #1 dialog. The state boundaries are polylines,
which are not true polygons because of the way they were digitized and stored.

From the Vector Window #1 dialog menu bar, select Edit > Edit Layer Properties. The Edit
Vector Layers dialog appears.

Select USA States [full range]. Change parameters for the state boundaries, including color, line
style, and thickness. To change the color, click on the colored box until you see the color you
want, or right-click on the colored box and select a color from the menu that appears. Click OK
when you are finished.

Clear the state boundaries by clicking USA States [full range] in the Available Vectors List,
then clicking Remove Selected.

Work with Vector Polygon Data

1.

From the Vector Window #1 dialog menu bar, select File > Open Vector File. A Select Vector
Filenames dialog appears.

Click the Files of type drop-down list in the Select Vector Filenames dialog, and select
Shapefile. Select states. shp and click Open. A Import Vector Files Parameters dialog
appears.

Select the Memory radio button, and accept the default values by clicking OK.

A status window reports the number of vector vertices being read, and the Available Vectors List
appears when the data have been converted. The vector layer states. shp is loaded into the
Available Vectors List.

In the Available Vectors List, select states . shp and click Load Selected. The Load Vector
dialog appears.

Select Vector Window #1 as the location to load the vector. Click OK. The cities and the state
boundaries both appear in the Vector Window #1 dialog. The state boundaries are polylines,
which are not true polygons because of the way they were digitized and stored.

From the Vector Window #1 dialog menu bar, select Edit > Edit Layer Properties. The Edit
Vector Layers dialog appears.

Select Layer:states.shp and change the color to green. Click the Polygon Fill drop-down list and
select Line. Click OK.

13
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Retrieve Vector Information and Attributes

1.

Right-click in the Vector Window #1 dialog and select Select Active Layer > Layer: cities.shp.
From the Vector Window #1 dialog menu bar, select Options > Vector Information to open the
Vector Information dialog. Click and drag over the city flags in the Vector Window #1 dialog to
see the basic attribute information (from cities.dbf) in the Vector Information dialog.

Find your hometown or a nearest city by examining the AREANAME attribute in the Vector
Information window. The latitude and longitude appear at the bottom of the Vector Window #1
dialog.

View Attributes and Use Point-and-Click Query

1.

While cities. shp is still the active layer and Cursor Query is the active mode, select Edit >
View/Edit/Query Attributes from the Vector Window #1 dialog menu bar. A Layer Attributes
table appears. This is a fully editable table of the attributes for the selected layer.

Click in the left column (on the record number) to do a spatial query on a selected city. The
corresponding city flag is highlighted in the Vector Window #1 dialog. If desired, zoom to the
selected city by clicking and dragging a box around it with the middle mouse button. Zoom back
out by clicking the middle mouse button in the Vector Window #1 dialog.

Verify that you have selected the correct city by clicking the city flag in the Vector Window #1
dialog and observing the attributes in the Vector Information window.

Edit the AREALAND value for the selected city by scrolling to the right in the Layer Attributes
table until you see the AREALAND column. Double-click in the corresponding AREALAND
table cell. Enter a new value and press <Enter> to change the value.

Perform a map-based query by clicking a city flag. The corresponding record is highlighted in the
Layer Attributes table. In the Vector Window #1 dialog, drag the vector cursor from one city flag
to another, and note how the Layer Attributes table scrolls to follow the selected cities.

Query Attributes

1.

N ok

Ensure that cities. shp is still the active layer. From the Vector Window #1 dialog menu bar,
select Options > Select Active Layer > Layer:cities.shp.

From the Vector Window #1 dialog menu bar, select Edit > Query Attributes. A Layer Attribute
Query dialog appears.

In the Query Layer Name field, enter Where State=—California. Click Start. A Query
Expression section appears at the top of the Layer Attribute Query dialog.

Click the AREANAME drop-down list and select ST.
Click the > drop-down list and select =.
In the String field, enter CA (be sure to match this case).

Click the Memory radio button and click OK. ENVI Classic creates a new vector layer and
associated DBF file based on the results of the query. The new layer appears in the Available
Vectors List and is loaded into Vector Window #1. Zoom to the selected vectors using the middle
mouse button to draw a box around the state of California.

14
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8.

10.

Right-click in the Vector Window #1 dialog and select Select Active Layer > Layer:Where
State==California. Open the DBF attribute file by selecting Edit > View/Edit/Query Attributes
from the Vector Window #1 dialog menu bar. The Layer Attributes table appears.

Perform some point-and-click query operations as described in the previous section to see the
association between the selected cities, their locations in the vector window, and their attributes.
You can select multiple cities from the attribute table by holding down the Ctrl key while you
click on the record labels on the left side of the table.

Click the AREANAME column name at the top of the table to highlight the entire set of
attributes. From the Layer Attributes table menu bar, select Options > Sort by selected column
forward to sort the column alphabetically. Scroll down the column and click the Sacramento row
(record 334) to highlight the location of California’s capital in a different color in the Vector
Window #1 dialog.

Add a Map Key in the Vector Window

You can generate a vector map from the Vector Window dialog, using annotation tools. See the tutorial
"Map Composition" on page 2 or ENVI Classic Help for further details. The following exercise shows
you how to add a map key.

1.

From the Vector Window #1 dialog menu bar, select Options > Annotate Plot. An Annotation
dialog appears.

From the Annotation dialog menu bar, select Object > Map Key to automatically create a map
key for the vector layers. Click once inside the Vector Window #1 dialog to show the map key,
and click and drag the red diamond handle to move it. To change the characteristics of the map
key, click Edit Map Key Items in the Annotations dialog and change the settings in the Map Key
Object Definition dialog.

Right-click in the Vector Window #1 dialog to lock the map key in place. Annotation in the vector
window behaves the same way as annotation in display groups.

The following image shows the results of the attribute queries and annotations; your results may
be slightly different.

15
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Part 2: Raster and Vector Processing

This section of the tutorial demonstrates how to use vector overlays and GIS data and attributes in
combination with raster images from Space Imaging/EOSAT.

Load Image Data to Combined Image/Vector Display

Open an image file to use as a backdrop for vector layers.

1.

From the ENVI Classic main menu bar, select File > Open Image File. A file selection dialog
appears.

Select 0826 ms.img. Click Open.

The Available Bands List appears with four spectral bands listed. The data simulate a 4 m Space
Imaging/EOSAT multispectral dataset with spectral band coverage similar to the first four
spectral bands of Landsat Thematic Mapper data. A true-color image is automatically loaded into
a new display group.

Open a Vector Layer and Load to Image Display

1.

From the Display group menu bar, select Overlay > Vectors. A Vector Parameters dialog
appears.

From the Vector Parameters dialog menu bar, select File > Open Vector File. This menu option
is also accessible from the ENVI Classic main menu bar. A Select Vector Filenames dialog
appears.

Click the Files of type: drop-down list and select Shapefile. Select vectors. shp and click
Open. An Import Vector Files Parameters dialog appears.

Select File or Memory output, and enter an output filename for the ENVI Classic .evf file if
you selected File.

In the Native Projection list, select State Plane (NAD 83). Click Set Zone. A Select State Plane
Zone dialog appears.

Select (404, 3351) California IV and click OK.

Select Memory output and click OK. A status window reports the number of vector vertices
being read. When the data have been converted, they are automatically loaded into the Vector
Parameters dialog and displayed in white on the image. The vectors.shp layer should be
highlighted in the Vector Parameters dialog.

Click the Current Layer colored box to select a more visible color for the vector layer or right-
click on the box and select from the menu. Click Apply to update the vector color.

Track Attributes with the Cursor

1.

In the Vector Parameters dialog, select Options > Vector Information. A Vector Information
dialog appears.

Click and drag inside the image to view the attribute information for the vectors. Also observe the
latitude and longitude listed in the Vector Parameters dialog. Select the Scroll or Zoom radio

17
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button in the Vector Parameters dialog to allow vector tracking in the corresponding window.
Select the Off radio button to allow normal scrolling in the Scroll and Main windows and zooming
in the Zoom window. Try different zoom factors in the Zoom window to assess the accuracy of
the vectors.

Ensure that you are in Cursor Query mode by selecting Mode from the Vector Parameter dialog
menu bar.

From the Vector Parameters dialog menu bar, select Edit > View/Edit/Query Attributes. A
Layer Attributes table appears. Select random records by clicking the numbered columns to
highlight specific polygons on the image. You may want to change the Current Highlight color in
the Vector Parameters dialog to something that is more visible in your display group.

Heads-up (On-screen) Digitizing

ENVI Classic provides vector editing routines for adding your own vectors to an existing vector layer or
for creating new vector layers. These vector editing routines are similar in function to annotation
polygons, polylines, and points. ENVI Classic heads-up vector digitizing allows you to create new
polygons, polylines, points, rectangles, and ellipses.

1.

A

Create a new vector layer by selecting File > Create New Layer from the Vector Parameters
dialog. A New Vector Layer Parameters dialog appears.

Enter a Layer Name. Click the Memory radio button, and click OK.
In the Vector Parameters dialog, click the new layer name to initialize a new DBF file.
From the Vector Parameters dialog menu bar, select Mode > Add New Vectors.

For this exercise, you will create a polygon vector. From the Vector Parameters dialog menu bar,
select Mode > Polygon.

Since the Image radio button is selected by default in the Vector Parameters dialog, you will
define the new polygon in the Image window. You can specify which display group window you
want to edit your vectors in, by selecting the appropriate radio button in the Vector Parameters
dialog.

You may want to change the new vector layer color from white to something more visible before
drawing new polygons.

Draw a few polygons using field outlines on the image as guides. In the Image window, use the
mouse to define the new polygon area as follows:

¢ Click the left mouse button to draw polygon segments.
o Click the middle mouse button to erase polygon segments.

o Click the right mouse button to fix the polygon. Right-click again and select Accept
New Polygon to accept the polygon.

e To move the Image box in the Scroll window to a new location, you must click the Off
radio button in the Vector Parameters dialog. When you are finished moving around the
image, click the Image radio button to resume adding new vectors.

7. To add attributes to the new polygons, select Edit > Add Attributes from the Vector Parameters

dialog menu bar. An Add Attributes Choice dialog appears.

18
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10.
11.
12.
13.
14.
15.

16.

Select Define new attributes interactively. Click OK. An Attribute Initialization dialog appears.
In the Name field, type Field ID.

Click the Type drop-down list and select Character.

Click Add Field.

For the second attribute, type Field Area in the Name field.

Click the Type drop-down list and select Numeric.

Click OK to create the attribute table. A Layer Attributes table appears.

Double-click in a field, enter the value, and press the Enter key. To see which rows are
associated with which fields, select Mode > Cursor Query from the Vector Parameters dialog,
and click the row labels in the Layer Attributes table. The corresponding polygon is highlighted in
the Image window.

From the Layer Attributes dialog menu bar, select File > Cancel. When you are prompted to save
the attribute table, click Yes.

Edit Vector Layers

1.

In the Vector Parameters dialog, select the new vector layer and select Mode > Edit Existing
Vectors.

In the Image window, click one of the polygons you created in the last section. The polygon is
highlighted and its nodes are marked with diamonds. When the vector is selected, you can make
the following changes:

e Delete the entire polygon by right-clicking it and selecting Delete Selected Vector.
e To move a node, click and drag it to a new location.
e After making changes to a polygon, right-click it and select Accept Changes.

o Exit the editing function without making any changes by clicking the middle mouse
button, or right-click and select Clear Selection.

To add or remove nodes from a polygon, right-click to display the shortcut menu and
select from the following options: (1) To add a node, right-click and select Add Node,
then drag the node to a new location. (2) To remove a node, right-click it and select
Delete Node from the shortcut menu. (3) To change the number of nodes added at one
time, right-click and select Number of Nodes to Add. Enter the number of nodes in the
dialog that appears. (4) To remove a range of nodes, right-click on the first node and
select Mark Node. Right-click on the last node and select Mark Node again. Right-
click again and select Delete Marked Nodes.

To finish this section, select Window > Available Vectors List from the ENVI Classic main
menu bar to display the Available Vectors List. Delete any new layers you have created by
selecting them in the Available Vectors List and clicking Remove Selected. Do not remove the
vectors. shp layer.
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Query Operations

L.
2.

10.

11.

12.

13.

14.

From the Vector Parameters dialog menu bar, select Mode > Cursor Query.

In the Vector Parameters dialog, highlight vectors. shp. Select Edit > View/Edit/Query
Attributes. A Layer Attributes table appears.

Examine the RANCH column and note the predominance of three owners “gloria”, “lanini”, and
“sharpe”. Close the attribute table by selecting File > Cancel.

From the Vector Parameters dialog menu bar, select Edit > Query Attributes. A Layer Attribute
Query dialog appears.

In the Query Layer Name field, type Gloria Ranch. Click Start.

In the Query Expression section that appears at the top of the Vector Parameters dialog, click the
AREA drop-down list and select RANCH.

Click the > drop-down list and select ==.
In the Value field, type gloria. (Be sure to match the case in the attribute table).

Select the Memory radio button and click OK. The Gloria Ranch layer generated by the query
appears in the Vector Parameters dialog.

In the Vector Parameters dialog, select the Gloria Ranch layer and select Edit > Edit Layer
Properties from the menu bar to change layer parameters. An Edit Vector Layers dialog appears.

Click the Polygon Fill drop-down list and select Line. Click OK. The Gloria Ranch polygons are
highlighted as a new layer.

To examine the attributes for this layer, select Gloria Ranch in the Vector Parameters dialog,
and select Edit > View/Edit/Query Attributes from the menu bar. A Layer Attributes table
appears. Examine the query results.

Close the Layer Attributes table and repeat the query for the "lanini" and "sharpe" ranches,
highlighting each in a different color or pattern.

Try other queries on combinations of attributes by choosing one of the logical operators in the
Layer Attribute Query dialog.

Convert Vectors to ROls

ENVI Classic provides several important links between vector analysis and raster image processing.
This portion of the exercise describes how to create ROIs from vector processing results and extract
ROI statistics.

1.

From the Display group menu bar, select Overlay > Region of Interest. The ROI Tool dialog
appears.

In the Vector Parameters dialog, highlight a layer name and select File > Export Active Layer
to ROIs. An Export EVF Layers to ROI dialog appears.

Select Convert all records of an EVF layer to one ROI, and click OK.

20



@ENV| ENVI Classic Tutorial: Vector Overlay and GIS Analysis

4. Repeat Steps 2-3 for each layer you created earlier from the query operations. The layers appear
in the ROI Tool dialog.

5. Inthe ROI Tool dialog, select the Gloria Ranch ROI by clicking in the far left column of its row.
Click Stats. An ROI Statistics Results dialog appears with image statistics for the Gloria Ranch
polygons and multispectral data.

Now that you have converted these vector polygons to ROIs, you can use ENVI Classic’s raster
processing capabilities to analyze the image data, with respect to the ROIs. This includes
masking, statistics, contrast stretching, and supervised classification.

Display Image Map Results

ENVI Classic provides tools to generate image maps from the combined raster/vector data in a display
group. These include annotation tools used for image and plot annotation, as well as QuickMap tools.
The following example shows you how to add a map key to the display group. See the tutorial "Map
Composition" on page 2 or ENVI Classic Help for further details on annotation.

1. From the Display group menu bar, select Overlay > Annotation. An Annotation dialog appears.
2. From the Annotation dialog menu bar, select Object > Map Key.

3. Click once inside the Image window to show the map key. Click and drag the diamond handle to
move the map key.

4. Click Edit Map Key Items in the Annotation dialog. A Map Key Object Definition dialog
appears. Change the map key characteristics as desired and click OK.

5. Once you have placed the map key where you want it, right-click in the Image window to lock it
in place.
Close Windows and Files

1. Inthe Available Vectors List, click Select All Layers, followed by Remove Selected. From the
Available Vectors List menu bar, select File > Cancel.

2. From the ENVI Classic main menu bar, select File > Close All Files.

Export ROl to Vector Layer

ENVI Classic can convert raster processing results (such as ROIs) for use in ENVI Classic vector
processing and analysis and for export to external GIS software such as ArcGIS. The following
exercises illustrate the export of raster information to vector GIS.

Open and Display an Image

Open a Landsat TM image of Cafion City, Colorado, USA, to use as background for ROI definition and
export to vector:

1. From the ENVI Classic main menu bar, select File > Open Image File. A file selection dialog
appears.

2. Select can tmr.img. Click Open.

3. Inthe Available Bands List, select TM Band 4, select the Gray Scale radio button, and click
Load Band.

21



ENVI Classic Tutorial: Vector Overlay and GIS Analysis @ENV|

Load Predefined ROls

1.

4.

From the Display group menu bar, select Overlay > Region of Interest. An ROI Tool dialog
appears.

From the ROI Tool dialog menu bar, select File > Restore ROIs.

Select can_tml.roi. Click Open. An ENVI Classic Message dialog reports what regions
have been restored. Click OK. The predefined ROI is loaded into the ROI Tool dialog and plotted
on the image.

Repeat Step 3 for the file can _tm2.roi.

Convert ROls to Vectors

1.

S

To convert these ROIs to vector polygons, select File > Export ROIs to EVF from the ROI Tool
dialog menu bar. An Export Region to EVF dialog appears.

Select a region from the Select ROIs to Export field.

Select All points as one record.

Enter an Output Layer Name, click Memory, and click OK to convert the first ROI.
Repeat Steps 1-4 for the second ROI. The layers appear in the Available Vectors List.

In the Available Vectors List, click Select All Layers, followed by Load Selected. A Load
Vector dialog appears.

Select New Vector Window and click OK. The vectors are loaded as polygons into the Vector
Window #1 dialog.

From the Vector Window #1 dialog menu bar, select Edit > Add Attributes.

Add attributes as described in Steps 8-15 on page 12. You can now use these polygons with query
operations and GIS analysis with other vector data, or you can export them to shapefiles by
selecting File > Export Active Layer to Shapefile from the Vector Window Parameters dialog.

Close All Windows and Files

1.
2.
3.
4.

In the Available Vectors List, click Select All Layers, followed by Remove Selected.
From the Available Vectors List menu bar, select File > Cancel.
From the Vector Window #1 dialog menu bar, select File > Cancel.

From the ENVI Classic main menu bar, select File > Close All Files.

Export a Classification Image to Vector Polygons

You can export classes from a classification image to one or more vector layers, and you can select
individual image brightness levels for export as a vector layer.

Load and Display a Classification Image

Open a parallelepiped classification image of Cafion City TM data (with three classes) to use as a
background for ROI definition and export to vector:
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1. From the ENVI Classic main menu bar, select File > Open Image File. A file selection dialog
appears.

2. Select can_pcls.img. Click Open.
3. Inthe Available Bands List, click Load Band.

Generalize the Classification Image

To conduct successful raster-to-vector conversions, you should typically generalize the results of raster
processing. If you do not generalize, you will have vector polygons around individual pixels and small
groups of pixels. To demonstrate the results of generalizing the classification image, load and display the
results of a 5-pixel sieve operation, followed by a 5 x 5 clump operation as follows:

1. Open and display can_sv.img (the sieve results) in Display #1, replacing can_pcls.img.
2. Open and display can_clmp.img (the clump results) in Display #1, replacing can_sv.img.
Convert the Generalized Classification Image to Vector Polygons

1. From the ENVI Classic main menu bar, select Classification > Post Classification >
Classification to Vector. A Raster to Vector Input Band dialog appears.

2. Select Clump under can_clmp. img and click OK. A Raster to Vector Parameters dialog
appears.

Select Region #1, press the Shift key, and select Region #2 (to select both).
Click the Output toggle button to select One Layer per Class.
Select Memory and click OK. The new vector layers appear in the Available Vectors List.

A

In the Available Vectors List, select Region #1, press the Shift key, and select Region #2 (to
select both).

~

Click Load Selected. A Load Vectors dialog appears.
8. Select Display #1 and click OK. A Vector Parameters dialog appears.

9. Inthe Vector Parameters dialog, select Region #1. Select Edit > Edit Layer Properties from
the Vector Parameters menu bar. An Edit Vectors Layers dialog appears.

10. Right-click the Color box and select Items 1:20 > White. Click the Polygon Fill drop-down list
and select Line. Click OK.

11. Inthe Vector Parameters dialog, select Region #2. Select Edit > Edit Layer Properties from
the Vector Parameters menu bar. An Edit Vectors Layers dialog appears.

12. Right-click the Color box and select Items 1:20 > Yellow. Click the Polygon Fill drop-down list
and select Line. Click OK.

13. Examine the results in Display #1. You can also overlay the vectors onto a gray scale image of
can_tmr.img Band 3 if desired. This overlay is show in the following figure.
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£ #1 TM Band 4:can_tmr.img

File ©Cwerlay Enhance Tools  Window

14. From the ENVI Classic main menu bar, select File > Exit.
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