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Spectral Angle Mapper (SAM) and Spectral
Information Divergence (SID) Classification

This tutorial provides an introduction to the Spectral Angle Mapper (SAM) and Spectral Information
Divergence (SID) supervised classification methods and compares the results produced by each method
on the same image.

Files Used in this Tutorial

Download data files from the Exelis website.

File Description

cup95eff.int AVIRIS atmospherically corrected reflectance data (50-band subset)
cup95eff.hdr ENVI header for above

jpll.sli Spectral library
Jpll.hdr Header file for above
Background

SAM and SID are both spectral measures. SAM is a deterministic method that looks for an exact pixel
match and weights the differences the same. SID is a probabilistic method that allows for variations in
pixel measurements, where probability is measured from zero to a user-defined threshold.

References

SAM: Kruse, F. A., A. B. Lefkoff, J. B. Boardman, K. B. Heidebrecht, A. T. Shapiro, P. J. Barloon,
and A. F. H. Goetz, 1993, “The Spectral Image Processing System (SIPS) - Interactive Visualization
and Analysis of Imaging spectrometer Data.” Remote Sensing of the Environment, v. 44, pp. 145-163.

SID: H. Du, C.-I. Chang, H. Ren, F.M. D’Amico, J. O. Jensen, J., 2004, “New Hyperspectral
Discrimination Measure for Spectral Characterization.” Optical Engineering, v. 43, No. 8, pp. 1777-
1786.
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Applying SAM Classification

SAM is a physically-based spectral classification that uses an n-dimensional angle to match pixels to
reference spectra. The algorithm determines the spectral similarity between two spectra by calculating
the angle between the spectra and treating them as vectors in a space with dimensionality equal to the
number of bands. When used on calibrated reflectance data, this technique is relatively insensitive to
illumination and albedo effects. Endmember spectra used by SAM can come from ASCII files or
spectral libraries, or you can extract them directly from an image (as ROI average or Z-profile spectra).
In this tutorial, you will use a spectral library.

SAM compares the angle between the endmember spectrum vector and each pixel spectrum vector in n-
D space. Smaller angles represent closer matches to the reference spectrum. Pixels further away than
the specified maximum angle threshold in radians are not classified.

Selecting the Files

1. From the ENVI® Classic main menu bar, select Classification > Supervised > Spectral Angle
Mapper. The Classification Input File dialog appears.

2. Click Open and select New File. The Please Select New File dialog appears.

3. Select cup95eff.int and click Open, followed by OK. The Endmember Collection:SAM
dialog appears.

Collecting Endmember Spectra

1. From the Endmember Collection:SAM dialog menu bar, select Import > from Spectral Library
file. The Spectral Input File dialog appears.

2. Click Open and select Spectral Library. The Please Select New File dialog appears.
3. Select jpll.s11i and click Open, followed by OK. The Input Spectral Library dialog appears.
4. Use Ctrl+click to select the following input spectra:
e ALUNITE SO-4A
e KAOLINITE WELL ORDERED PS-1A
Click OK. The selections are added to the Endmember Collection:SAM dialog.

5. Right-click in each Color cell and change the color for each spectrum to what is shown in the
dialog example below.
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£ Endmember Collection:SAM EWE”E]
File Import Algorithm  Options  Help

File: cup95eff.int [Full Scene]
Mazk: <none selected:
Wawelength: 1.9908 to 2479 <unkrown unitz:

50 bands [1-50]
Spectum Name Color |
1 JALUNITE S0-44 Caial -

2 |FAOLIMITE WELL ORDERED EGLFELEN

< >

Selectall ||| Piot | Delete |

Apply | Cancel

6. Click Apply. The Spectral Angle Mapper Parameters dialog appears.

Setting SAM Parameters

1. Use the default thresholding option Single Value and keep the default setting of 0.1 for Maximum
Angle (radians). This parameter defines the maximum acceptable angle between the endmember
spectrum vector and the pixel vector (in # of bands dimensional space). SAM will not classify
pixels with an angle larger than this value.

2. Output the classification to a File and enter the filename cup95eff sam.out.

3. Set the Output Rule Images? toggle button to Yes and enter the filename cup95eff
sam.rule.

4. Click Preview to see a 256 x 256 spatial subset from the center of the output classification image.
Your Spectral Angle Mapper Parameters dialog and preview window should look similar to this:
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& Spectral Angle Mapper Parameters

Set Maxewm Angle [radians)

(" Mone * SingleValue O Muliple Values

M aximum Angle [radians]|0.100

Output Resultto & File © Memory

Enter Output Filename Choose | [T Compress

C:hervidatahc95avaubhoupS5efl_sam. out

Dutput Fule Images 7 [‘E ﬂ

Outpudt Resultto & Fle  Memorny

Ernber Output Rule Flename Choose

||::"-.em'idda\cgﬁa'vsuh't.l::l..pﬂﬁaff_sam.1ub

OK | Oueue | Cancel | Help ||| Preview |

(You can optionally change the parameters if needed and click Preview again to update the
display.)

5. Click OK. ENVI Classic adds the cup95eff sam.out and cup95eff sam.rule files to
the Available Bands List.

--f5. cup3%eff_sam out
O Sam [cup35eff.int]
=@l cup95eft_sam.mule
O Rule [ALUNITE 50-44)
O Rule [KAOLIMITE WELL ORD

The cup95eff sam.out file is the classified image. The cup95eff sam.rule file is the
rule file, which contains one image for Alunite and one image for Kaolinite.

SAM Output

In the Available Bands List, right-click Rule (ALUNITE SO-4A) under cup95eff sam.rule, then
select Load Band to New Display. Right-click on Sam (cup95eff.int), then select Load Band to New

Display. This opens Display groups loaded with the SAM rule image for Alunite (below left) and the
SAM classification image (below right).
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In the SAM Alunite rule image, the pixel values of the rule image represent the spectral angle in radians
from the reference spectrum for each class. Lower spectral angles represent better matches to the
endmember spectra. Areas that satisfied the selected radian threshold criteria were carried over as
classified areas into the classified image. In the example below, the SAM classification image shows
areas classified as Alunite (coral) and Kaolinite (aquamarine). Unclassified areas are black.

* #1 Rule (ALUNITE SO-4A):cup95eff_sam.rule |- [0 X | & #2 Sam (cup95eff.int):cup95eff_sam.out

Note: If you find it more intuitive to show the best matches to the endmember spectra as brighter pixel
values (as opposed to darker values, which is the default with SAM), follow these steps: From the #1
display group menu bar (Rule...), select Tools > Color Mapping > Control RGB Image Planes. In the
RGB Channels dialog, click all three Normal toggle buttons to select Inverse. From the RGB Channels
dialog menu bar, select Options > Apply.

Next, you will run the SID classification on the cup95eff. int file.
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Applying SID Classification

SID is a spectral classification method that uses a divergence measure to match pixels to reference
spectra. The smaller the divergence, the more likely the pixels are similar. Pixels with a measurement
greater than the specified maximum divergence threshold are not classified. Endmember spectra used by
SID can come from ASCII files or spectral libraries, or you can extract them directly from an image (as
ROI average or Z-profile spectra). In this tutorial, you will use a spectral library.

Selecting the Files

1. From the ENVI Classic main menu bar, select Classification > Supervised > Spectral
Information Divergence. The Classification Input File dialog appears.

2. Select the cup95eff. int file that was previously opened for the SAM classification, then
click OK. The Endmember Collection:SID dialog appears.

Collecting Endmember Spectra

1. From the Endmember Collection:SID dialog menu bar, select Import > from Spectral Library
file. The Spectral Input File dialog appears.

2. Select jpll.sli, then click OK. The Input Spectral Library dialog appears.
3. Use Ctrl+click to select the following input spectra:

ALUNITE SO-4A

KAOLINITE WELL ORDERED PS-1A

Click OK. The selections are added to the Endmember Collection:SID dialog.

4. Right-click in each Color cell and change the color for each spectrum to what is shown in the
dialog example on the right.

5. Click Apply. The Spectral Information Divergence Parameters dialog appears.

Setting SID Parameters

1. Use the default thresholding option Single Value and change the Maximum Divergence
Threshold to .08. This is the minimum allowable variation between the endmember spectrum
vector and the pixel vector. The default value is .05, but it can vary substantially given the nature
of the similarity measure. A threshold that discriminates well for one pair of spectral vectors may
be either too sensitive, or not sensitive enough, for another pair due to the similar/dissimilar nature
of their probability distributions. For the purpose of this exercise, a setting of .08 provides a SID
result that is similar to the one produced by SAM.

2. Output the classification to a File and enter the filename cup95eff sid.out.

3. Set the Output Rule Images? toggle button to Yes and enter the filename cup95eff
sid.rule.
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4. Click Preview to see a 256 x 256 spatial subset from the center of the output classification image.
Y our Spectral Information Divergence Parameters dialog and preview window should look similar

to this:

& Spectral Information Divergence Parameters g

Clazzalicabon Preview

Set Mawmum Divergence Thieshold:
(" Mone (¢ SingleValue © Multiple Values

Maimum Divergence Theeshold: |0.080

Output Besultto & File © Memorp

Enter Qutput Filename Choose | [T Compress

C:hervidatahc95avsubhoupSSef_sid out

Output Rule Images ?[Yes §1 |

r: : :

Eriter Dutput Rule Flename Choose
|I::\amﬂda\cﬂﬁwsuh\nmﬂﬁeff_sid ke

oK | Queve | Cancel | Hebp ||| Preview |

(You can optionally change the parameters if needed and click Preview again to update the
display.)

5. Click OK. ENVI Classic adds the cup95eff sid.out and cup95eff sid.rule files to
the Available Bands List.

The cup95eff sid.out file is the classified image. The cup95eff sid.rule is the rule
file, which contains one image for Alunite and one image for Kaolinite.

SID Output

In the Available Bands List, right-click on Rule (ALUNITE SO-4A) under cup95eff sid.rule,
then select Load Band to New Display. Right-click on Sid (cup95eff.int), then select Load Band to
New Display. This opens Display groups loaded with the SID rule image for Alunite (below left) and
the SID classification image (below right).

In the SID Alunite rule image, the pixel values of the rule image represent the SID value (the output of
the equation that defines SID for a pair of spectral vectors). Lower spectral divergence measures
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represent better matches to the endmember spectra. Areas that satisfied the maximum divergence
threshold criteria were carried over as classified areas into the classified image. In the example below,
the SID classification image shows areas classified as Alunite (coral) and Kaolinite (aquamarine).
Unclassified areas are black.

Note: If you find it more intuitive to show the best matches to the endmember spectra as brighter pixel
values (as opposed to darker values, which is the default with SID), follow these steps: From the #1
display group menu bar (Rule), select Tools > Color Mapping > Control RGB Image Planes. In the
RGB Channels dialog, click all three Normal toggle buttons to select Inverse. From the RGB Channels
dialog menu bar, select Options > Apply.

Next, you will examine the SAM and SID classification images side-by-side.

Comparing SAM and SID Output

When you view the SAM (right) and SID (left) classification images side-by-side, you see that the
results are similar, although the SAM output appears to have more noise.
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Next, you will examine three regions of the original image and compare the spectral profile in the
original image to the known Alunite SO-4A spectral signature from the Spectral Library. To prepare for
this, do the following:

1.
2.
3.

In the Available Bands List, click Display #4 and sclect New Display.
In the Available Bands List, select RGB Color.

Scroll down the Available Bands List to the cup95eff. int image and choose Band 174 = R,
Band 188 = G, and Band 200 = B, then click Load RGB.

Right click in the #5 Display group (the original image) and select Pixel Locator. The Pixel
Locator dialog appears.

From the #5 Display group menu bar, select Tools > Profiles > Z Profile (Spectrum). The
Spectral Profile:cup95eff. int plot appears.

From the ENVI Classic main menu bar, select Spectral > Spectral Libraries > Spectral
Library Viewer. The Spectral Library Input File dialog appears.

Select jpll.s1li, then click OK. The Spectral Library Viewer appears.
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10.

11.

12.
13.

Click on ALUNITE SO-4A. The Spectral Library plot for Alunite appears.
Close the Spectral Library Viewer.

From the Spectral Library Plots menu bar, select Edit > Plot Parameters. The Plot Parameters
dialog appears.

Change the Plot Title to Alunite SO-4A and the Range from 2.0 to 2.5. Click Apply, then click
Cancel to close the dialog.

Right-click in the #5 Display group and select Link Displays. The Link Displays dialog appears.

Link Display groups 2, 4, and 5 (the SAM classification image, the SID classification image, and
the original image), then click OK.

Examining an Area Classified as Alunite

The first area you will examine is one that both SAM and SID classified as Alunite.

L.

In the Pixel Locator, enter 304 for Sample and 543 for Line, then click Apply. The cursor moves
to the specified area in Display groups 2, 4, and 5. When you compare the SAM and SID Display
groups, you can see that both classified this pixel as Alunite because it appears as the coral color.
In the original image, this pixel appears as purple.

& #5 (R:Band 174,G:Band 188,8:Band 200):cup... [= |[B]]

Sample 304
Line 543
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2. Compare the Spectral Profile for this pixel to the known signature for Alunite SO-4A from the
Spectral Library. The signatures are similar to each other, confirming that SAM and SID were
correct in classifying this pixel as Alunite.

Sam SID cup95eff.int
&) C[Efx “
I'_ " .1'1'-.::
aar o
= L ] . I.
‘ -
-
I:I Ch -
5 —

Alunite SO—44

Known Alunite SO-44 signature and pixel (304, 543) spectral signature are similar

Examining an Area not Classified as Alunite

The next area you will examine is one that neither SAM nor SID classified as Alunite.

1. In the Pixel Locator, enter 519 for Sample and 395 for Line, then click Apply. The cursor moves
to the specified area in Display groups 2, 4, and 5. When you compare the SAM and SID Display
groups, you can see that neither classified this pixel as Alunite. Instead, both methods classified
this pixel as Kaolinite. In the original image, this pixel is not purple.
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& #5 (R:Band 174,G:Band 188 B:Band 200):cup... |= |0 X

Sample 519
fAlipessis g " .

2. Compare the Spectral Profile for this pixel to the known signature for Alunite SO-4A from the
Spectral Library. The signatures are not similar to each other, confirming that SAM and SID were
correct in not classifying this pixel as Alunite. If you open a new Spectral Library plot containing
Kaolinite, you will see that the Spectral Profile more closely resembles Kaolinite.

Page 13 of 16
© 2014 Exelis Visual Information Solutions, Inc. All Rights Reserved. This information is not subject to the controls
of the International Traffic in Arms Regulations (ITAR) or the Export Administration Regulations (EAR). However,
this information may be restricted from transfer to various embargoed countries under U.S. laws and regulations.



EXELIS

Visual Information Solutions

cup95eff.int

& ¥5 Spectral Profile:cup95eff.int

Fle Edt Options Plok_Function Help

Spactral Profile

Known Alunite SO-44A signature and pixel (519, 395) spectral signature are not similar

Examining an Area Classified Differently by SAM and SID for
Alunite

The last area you will examine is a large area in the upper right of the image that SAM classified as
Alunite, but SID did not.

1. In the Pixel Locator, enter 570 for Sample and 420 for Line, then click Apply. The cursor moves
to the specified area in Display groups 2, 4, and 5. When you compare the SAM and SID Display
groups, you can see that SAM clearly classified this pixel as Alunite, but SID did not classify this
pixel at all. In the original image, this pixel is not purple.
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& #5 (R:Band 174,G:Band 188,8:Band 200):cup... [= |[B]X]
Fle Overlay Enhance Tools Window

¥
Sample 570
Aine 420

2. Compare the Spectral Profile for this pixel to the known signature for Alunite SO-4A from the
Spectral Library. The signatures are not similar to each other. SAM classified this pixel as
Alunite, but it is a false positive. SID was correct in leaving this pixel unclassified. It is neither
Alunite nor Kaolinite.
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cup95eff.int

Known Alunite S0-4A signature and pizel (570, 420) spectral signature are not similar

3. When you are finished examining results, you can quit your ENVI Classic session by selecting
File > Exit from the ENVI Classic main menu bar.

Copyright Notice:
ENVI Classic is a registered trademark of Exelis Inc.

QUAC and FLAASH are registered trademarks of Spectral Sciences, Inc.
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